Signups temporarily paused
Incident Report for hCaptcha
Resolved
Dashboard maintenance is now complete.
Posted Apr 17, 2020 - 23:00 UTC
Identified
New user signups are temporarily paused on the dashboard during maintenance. This restriction will be lifted in approximately 10 minutes. All other dashboard features are working normally.
Posted Apr 17, 2020 - 21:47 UTC
This incident affected: Dashboard.