Increased endpoint latency in some regions

Incident Report for hCaptcha

Resolved

This incident has been resolved.
Posted Sep 11, 2026 - 14:20 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 11, 2026 - 14:12 UTC

Investigating

We are observing higher than expected latency at our edge in some regions, primarily affecting 0.0175% of siteverify requests. Affected traffic is now being rerouted, and we expect latency to recover shortly.
Posted Sep 11, 2026 - 14:04 UTC
This incident affected: Captcha API.