Dashboard under maintenance
Incident Report for hCaptcha
Resolved
This incident has been resolved.
Posted Mar 18, 2020 - 04:06 UTC
Identified
Dashboard statistics and sitekey-related data may fail to load for some users during maintenance. Other functions will remain available.
Posted Mar 18, 2020 - 02:01 UTC
This incident affected: Dashboard.