Dashboard under maintenance
Incident Report for hCaptcha
Resolved
This incident has been resolved.
Posted Jun 16, 2023 - 18:55 UTC
Investigating
Login error rates will increase on dashboard logins in some regions during subsystem maintenance.
Posted Jun 16, 2023 - 18:50 UTC
This incident affected: Dashboard.