Sitekey settings changes slow to update

Incident Report for hCaptcha

Resolved

This incident has been resolved.
Posted Jul 01, 2020 - 17:08 UTC

Investigating

Sitekey settings changes made via the dashboard are currently propagating slowly in some regions.
Posted Jul 01, 2020 - 15:02 UTC
This incident affected: Dashboard.