Dashboard under maintenance

Incident Report for hCaptcha

Resolved

This incident has been resolved.
Posted Aug 22, 2020 - 02:10 UTC

Identified

The dashboard is currently under maintenance, and will not be available for login in some regions over the next 10 minutes.
Posted Aug 22, 2020 - 02:04 UTC
This incident affected: Dashboard.