Dashboard updates may take longer than usual

Incident Report for hCaptcha

Resolved

This incident has been resolved.
Posted Dec 18, 2020 - 00:24 UTC

Identified

Updates made to sitekeys and account settings make take longer than usual to be reflected in the live production service for some users while queue maintenance is underway. This will affect approximately 5% of users in the EU region.
Posted Dec 17, 2020 - 21:35 UTC
This incident affected: Dashboard.