Elevated error rates on siteverify

Incident Report for hCaptcha

Postmortem

This issue was caused by a rollout of new code that contained a bug for some combinations of feature flags and request data. This should have been caught by other safeguards, but due to an unrelated change in the system those safeguards no longer triggered in this case. Improvements to the affected systems have been scheduled.

Posted 4 years ago. Jan 19, 2021 - 22:38 UTC

Resolved

Approximately 0.009% of requests to siteverify with some challenge modes received an `invalid-passcode` response, starting around 1:20PM PT and continuing for ~30 minutes. This affected less than 1% of sites.
Posted 4 years ago. Jan 19, 2021 - 21:30 UTC