Dashboard under maintenance
Incident Report for hCaptcha
Resolved
This incident has been resolved.
Posted May 15, 2020 - 13:38 UTC
Identified
The dashboard is being upgraded, and some features may be temporarily unavailable for several minutes.
Posted May 15, 2020 - 13:20 UTC
This incident affected: Dashboard.