Sitekey config changes and stats updating slower than usual

Incident Report for hCaptcha

Resolved

This incident has been resolved.
Posted May 23, 2020 - 00:55 UTC

Monitoring

Performance should now be normal in most regions.
Posted May 23, 2020 - 00:26 UTC

Identified

Sitekey config changes and metrics updates may take longer than usual to take effect as we perform maintenance on related queue infrastructure.
Posted May 22, 2020 - 21:40 UTC
This incident affected: Dashboard and Stats API.