Increased error rates for Google SSO due to Google outage

Incident Report for hCaptcha

Resolved

Error rates for Google SSO appear to have returned to normal.
Posted Jun 12, 2025 - 20:45 UTC

Identified

Due to an incident at Google, we are observing increased error rates on login authentication. Use GitHub SSO or contact support@hcaptcha.com if you need assistance with alternate methods.

You may track status here: https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW#2c2sBHWU84yPDJ8y1ar4
Posted Jun 12, 2025 - 19:01 UTC
This incident affected: Dashboard.