Signups paused
Incident Report for hCaptcha
Resolved
This incident has been resolved.
Posted Apr 24, 2020 - 16:46 UTC
Identified
Signups are temporarily paused while the dashboard is under maintenance.
Posted Apr 24, 2020 - 15:57 UTC
This incident affected: Dashboard.